Skip to content

← Actionable
Medium, CVSS 6.5

Spree API has Authenticated Insecure Direct Object Reference (IDOR) via Order Modification

CVE-2026-22588GHSA-g268-72p7-9j6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_api 5.2.5, 5.1.9, 5.0.7, 4.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems spree_api

    Affected
    >= 3.7.0, < 4.10.2>= 5.0.0, < 5.0.7>= 5.1.0, < 5.1.9>= 5.2.0, < 5.2.5
    Fixed in
    5.2.5, 5.1.9, 4.10.2, 5.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-22588: 0.41% estimated exploitation activity in the next 30 days; percentile 34.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An Authenticated Insecure Direct Object Reference (IDOR) vulnerability was identified that allows an authenticated user to retrieve other users’ address information by modifying an existing order. By editing an order they legitimately own and manipulating address identifiers in the request, the backend server accepts and processes references to addresses belonging to other users, subsequently associating those addresses with the attacker’s order and returning them in the response. Details Affected Component(s) - Authenticated user order management - Address association logic - Order update endpoint(s) Affected Endpoint(s): - /api/v2/storefront/checkout The application fails to enforce proper object-level authorization when updating an existing order. While the user is authenticated and authorized to modify their own order, the backend does not verify that the supplied address identifiers belong to the same authenticated user. PoC Preconditions - Valid authenticated user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g268-72p7-9j6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22588

Advisory: Spree API has Authenticated Insecure Direct Object Reference (IDOR) via Order Modification
IDs: CVE-2026-22588, GHSA-g268-72p7-9j6j
Record: https://patchnext.com/advisories/cve-2026-22588 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spree_api 5.2.5, 5.1.9, 5.0.7, 4.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems spree_api: affected >= 3.7.0, < 4.10.2; >= 5.0.0, < 5.0.7; >= 5.1.0, < 5.1.9; >= 5.2.0, < 5.2.5; fixed in 5.2.5, 5.1.9, 4.10.2, 5.0.7

## Suggested inspection (read-only)
- RubyGems spree_api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spree_api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g268-72p7-9j6j (GitHub-reviewed advisory GHSA-g268-72p7-9j6j lists affected ranges: RubyGems spree_api >=3.7.0 =5.0.0 =5.1.0 =5.2.0 <5.2.5)

Commands are suggestions: review each one before running it.

Loading voting…