Skip to content

← Actionable
Medium, CVSS 6.7amended

[Eclipse Theia] Data Exfiltration via Markdown Image Rendering in AI Chat

CVE-2026-22551GHSA-qwjm-9c66-w4q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@theia/ai-code-completion 1.71.0; @theia/ai-claude-code 1.71.0; @theia/ai-chat-ui 1.71.0; @theia/ai-core 1.71.0; @theia/ai-editor 1.71.0; 2 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.7 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22551: 0.31% estimated exploitation activity in the next 30 days; percentile 24.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Eclipse Theia versions prior to 1.71.0, the AI chat rendered Markdown image tags from AI responses, triggering HTTP requests to arbitrary external URLs without restriction. Combined with prompt injection in a malicious workspace, an attacker could induce the AI agent to construct image URLs encoding sensitive information from the workspace or conversation context, exfiltrating it to attacker-controlled servers. The workspace trust enforcement introduced in v1.71.0 mitigates the documented attack chain by disabling AI features in untrusted workspaces.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qwjm-9c66-w4q4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qwjm-9c66-w4q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22551

Advisory: [Eclipse Theia] Data Exfiltration via Markdown Image Rendering in AI Chat
IDs: CVE-2026-22551, GHSA-qwjm-9c66-w4q4
Record: https://patchnext.com/advisories/cve-2026-22551 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @theia/ai-code-completion 1.71.0; @theia/ai-claude-code 1.71.0; @theia/ai-chat-ui 1.71.0; @theia/ai-core 1.71.0; @theia/ai-editor 1.71.0; @theia/ai-chat 1.71.0; @theia/ai-ide 1.71.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @theia/ai-code-completion: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-claude-code: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-chat-ui: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-core: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-editor: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-chat: affected < 1.71.0; fixed in 1.71.0
- npm @theia/ai-ide: affected < 1.71.0; fixed in 1.71.0

## Suggested inspection (read-only)
- `npm ls @theia/ai-code-completion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-chat-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @theia/ai-ide --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @theia/ai-code-completion, @theia/ai-claude-code, @theia/ai-chat-ui, @theia/ai-core, @theia/ai-editor, @theia/ai-chat, @theia/ai-ide.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qwjm-9c66-w4q4 (OSV record GHSA-qwjm-9c66-w4q4 lists affected ranges: npm @theia/ai-chat-ui >=0 =0 =0 =0 =0 =0 =0 <1.71.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qwjm-9c66-w4q4 (GitHub-reviewed advisory GHSA-qwjm-9c66-w4q4 lists affected ranges: npm @theia/ai-chat-ui >=0 =0 =0 =0 =0 =0 =0 <1.71.0)

Commands are suggestions: review each one before running it.

Loading voting…