Skip to content

← Actionable
High, CVSS 7.1

Apache Solr: Insufficient file-access checking in standalone core-creation requests

CVE-2026-22444GHSA-vc2w-4v3p-2mqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-22444: 0.69% estimated exploitation activity in the next 30 days; percentile 52.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element . These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem. On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes. Solr deployments are subject to this vulnerability if they meet the following criteria: Solr is running in its "standalone" mode. Solr's "allowPath" setting is being used to restrict file access to certain directories. Solr's "create core" API is exposed and accessible to untrusted users. This can happen if Solr's RuleBasedAuthorizationPlugin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vc2w-4v3p-2mqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22444

Advisory: Apache Solr: Insufficient file-access checking in standalone core-creation requests
IDs: CVE-2026-22444, GHSA-vc2w-4v3p-2mqw
Record: https://patchnext.com/advisories/cve-2026-22444 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 8.6.0, < 9.10.1; fixed in 9.10.1

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vc2w-4v3p-2mqw (GitHub-reviewed advisory GHSA-vc2w-4v3p-2mqw lists affected ranges: Maven org.apache.solr:solr-core >=8.6.0 <9.10.1)

Commands are suggestions: review each one before running it.

Loading voting…