Skip to content

← Actionable
High, CVSS 8.7

EGroupware has SQL Injection in Nextmatch Filter Processing

CVE-2026-22243GHSA-rvxj-7f72-mhrx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (egroupware/egroupware 26.0.20260113, 23.1.20260113), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist egroupware/egroupware

    Affected
    < 23.1.20260113>= 26.0.20251208, < 26.0.20260113
    Fixed in
    23.1.20260113, 26.0.20260113

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-22243: 0.43% estimated exploitation activity in the next 30 days; percentile 37.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Critical Authenticated SQL Injection in Nextmatch Widget Filter Processing A critical SQL Injection vulnerability exists in the core components of EGroupware, specifically in the Nextmatch filter processing. The flaw allows authenticated attackers to inject arbitrary SQL commands into the WHERE clause of database queries. This is achieved by exploiting a PHP type juggling issue where JSON decoding converts numeric strings into integers, bypassing the isint() security check used by the application. Details Root Cause Analysis The vulnerability exists in how the database abstraction layer (Api\Db) and high-level storage classes (Api\Storage\Base, infologso) process the colfilter array used in "Nextmatch" widgets. The application attempts to validate input using isint($key) to determine if an array key represents a raw SQL fragment that should be trusted. However, when processing JSON-based POST requests, PHP's jsondecode automatically converts numeric string keys (e.g., "0")…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rvxj-7f72-mhrx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22243

Advisory: EGroupware has SQL Injection in Nextmatch Filter Processing
IDs: CVE-2026-22243, GHSA-rvxj-7f72-mhrx
Record: https://patchnext.com/advisories/cve-2026-22243 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: egroupware/egroupware 26.0.20260113, 23.1.20260113. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist egroupware/egroupware: affected < 23.1.20260113; >= 26.0.20251208, < 26.0.20260113; fixed in 23.1.20260113, 26.0.20260113

## Suggested inspection (read-only)
- Packagist egroupware/egroupware: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on egroupware/egroupware.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rvxj-7f72-mhrx (GitHub-reviewed advisory GHSA-rvxj-7f72-mhrx lists affected ranges: Packagist egroupware/egroupware >=0 =26.0.20251208 <26.0.20260113)

Commands are suggestions: review each one before running it.

Loading voting…