CoreShop Vulnerable to SQL Injection via Admin Reports
CVE-2026-22242GHSA-ch7p-mpv4-4vg4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (coreshop/core-shop 4.1.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist coreshop/core-shop
- Affected
- <= 4.1.7
- Fixed in
- 4.1.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ch7p-mpv4-4vg4 lists affected ranges: Packagist coreshop/core-shop >=0 <=4.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-22242: 0.43% estimated exploitation activity in the next 30 days; percentile 36.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Version(s) - CoreShop 4.1.2 Demo (tested) Demo | CoreShop - Earlier versions may also be affected if the same code path exists Summary A blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. Details The vulnerability occurs due to unsanitized user input being concatenated into a SQL query without proper parameterization. An attacker with administrative access can manipulate the affected parameter to influence the backend SQL query logic. Although no direct query output is returned, boolean and time-based inference techniques allow an attacker to extract data from the database. Impact Vulnerability Type: Blind SQL Injection Impact: Confidentiality only An attacker…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ch7p-mpv4-4vg4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22242 Advisory: CoreShop Vulnerable to SQL Injection via Admin Reports IDs: CVE-2026-22242, GHSA-ch7p-mpv4-4vg4 Record: https://patchnext.com/advisories/cve-2026-22242 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: coreshop/core-shop 4.1.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist coreshop/core-shop: affected <= 4.1.7; fixed in 4.1.8 ## Suggested inspection (read-only) - Packagist coreshop/core-shop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on coreshop/core-shop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ch7p-mpv4-4vg4 (GitHub-reviewed advisory GHSA-ch7p-mpv4-4vg4 lists affected ranges: Packagist coreshop/core-shop >=0 <=4.1.7) Commands are suggestions: review each one before running it.
Loading voting…