Skip to content

← Actionable
High, CVSS 8.3amended

Chainlit contain a server-side request forgery (SSRF) vulnerability

CVE-2026-22219GHSA-2g59-m95p-pgfq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainlit 2.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI chainlit

    Affected
    < 2.9.4
    Fixed in
    2.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-22219: 5.17% estimated exploitation activity in the next 30 days; percentile 92.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Chainlit versions prior to 2.9.4 contain a server-side request forgery (SSRF) vulnerability in the /project/element update flow when configured with the SQLAlchemy data layer backend. An authenticated client can provide a user-controlled url value in an Element, which is fetched by the SQLAlchemy element creation logic using an outbound HTTP GET request. This allows an attacker to make arbitrary HTTP requests from the Chainlit server to internal network services or cloud metadata endpoints and store the retrieved responses via the configured storage provider.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2g59-m95p-pgfq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2g59-m95p-pgfq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22219

Advisory: Chainlit contain a server-side request forgery (SSRF) vulnerability
IDs: CVE-2026-22219, GHSA-2g59-m95p-pgfq
Record: https://patchnext.com/advisories/cve-2026-22219 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chainlit 2.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI chainlit: affected < 2.9.4; fixed in 2.9.4

## Suggested inspection (read-only)
- `python -m pip show chainlit`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chainlit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2g59-m95p-pgfq (OSV record GHSA-2g59-m95p-pgfq lists affected ranges: PyPI chainlit >=0 <2.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-2g59-m95p-pgfq (GitHub-reviewed advisory GHSA-2g59-m95p-pgfq lists affected ranges: PyPI chainlit >=0 <2.9.4)

Commands are suggestions: review each one before running it.

Loading voting…