Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw: Unified root-bound write hardening for browser output and related path-boundary flows

CVE-2026-22180GHSA-3pxq-f3cp-jmxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.1
    Fixed in
    2026.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-22180: 0.14% estimated exploitation activity in the next 30 days; percentile 3.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path-confinement bypass in browser output handling allowed writes outside intended roots in openclaw versions up to and including 2026.3.1. The fix unifies root-bound, file-descriptor-verified write semantics and canonical path-boundary validation across browser output and related install/skills write paths. Affected Packages / Versions - Package: openclaw (npm) - Latest published npm version at triage time: 2026.3.1 - Affected range: <= 2026.3.1 - Patched release: 2026.3.2 (released) Fix Commit(s) - 104d32bb64cdf19d5e77f70553a511a2ae90ad1c Technical Notes - Browser output writes now use root-bound, fd/inode-verified commit flow. - Install + skills path checks now share canonical in-base validation to reduce drift and close equivalent escape surfaces. - Added regression coverage for symlink-rebind and root-bound source-path write behavior.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3pxq-f3cp-jmxp

  2. Revision 1 · created ·

    Published from osv record GHSA-3pxq-f3cp-jmxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22180

Advisory: OpenClaw: Unified root-bound write hardening for browser output and related path-boundary flows
IDs: CVE-2026-22180, GHSA-3pxq-f3cp-jmxp
Record: https://patchnext.com/advisories/cve-2026-22180 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.1; fixed in 2026.3.2

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3pxq-f3cp-jmxp (OSV record GHSA-3pxq-f3cp-jmxp lists affected ranges: npm openclaw >=0 <2026.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3pxq-f3cp-jmxp (GitHub-reviewed advisory GHSA-3pxq-f3cp-jmxp lists affected ranges: npm openclaw >=0 <=2026.3.1)

Commands are suggestions: review each one before running it.

Loading voting…