OpenClaw's exec allow-always can be bypassed via unrecognized multiplexer shell wrappers (busybox/toybox sh -c)
CVE-2026-22175GHSA-gwqp-86q6-w47g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.23
- Fixed in
- 2026.2.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gwqp-86q6-w47g lists affected ranges: npm openclaw >=0 <2026.2.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwqp-86q6-w47g lists affected ranges: npm openclaw >=0 <2026.2.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-22175: 0.35% estimated exploitation activity in the next 30 days; percentile 28.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OpenClaw exec approvals could be bypassed in allowlist mode when allow-always was granted through unrecognized multiplexer shell wrappers (notably busybox sh -c and toybox sh -c). Affected Packages / Versions - Package: openclaw (npm) - Affected: <= 2026.2.22-2 - Latest published vulnerable version at triage time: 2026.2.22-2 (checked on February 24, 2026) - Fixed on main: yes - Patched release: 2026.2.23 Details Wrapper analysis treated busybox/toybox invocations as non-wrapper commands in this path, so allow-always persisted the wrapper binary path instead of the inner executable. That allowed later arbitrary payloads under the same multiplexer wrapper to satisfy the stored allowlist rule. The fix hardens wrapper detection and persistence behavior for these multiplexer shell applets so approvals bind to intended inner executables and fail closed when unwrap safety is uncertain. Fix Commit(s) - a67689a7e3ad494b6637c76235a664322d526f9e Release Process Note patchedversions is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-gwqp-86q6-w47g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-gwqp-86q6-w47g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22175 Advisory: OpenClaw's exec allow-always can be bypassed via unrecognized multiplexer shell wrappers (busybox/toybox sh -c) IDs: CVE-2026-22175, GHSA-gwqp-86q6-w47g Record: https://patchnext.com/advisories/cve-2026-22175 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.23; fixed in 2026.2.23 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gwqp-86q6-w47g (OSV record GHSA-gwqp-86q6-w47g lists affected ranges: npm openclaw >=0 <2026.2.23 (fixed)) - Verified: https://github.com/advisories/GHSA-gwqp-86q6-w47g (GitHub-reviewed advisory GHSA-gwqp-86q6-w47g lists affected ranges: npm openclaw >=0 <2026.2.23) Commands are suggestions: review each one before running it.
Loading voting…