Skip to content

← Actionable
Critical, CVSS 9.9amended

OpenClaw: WebSocket shared-auth connections could self-declare elevated scopes

CVE-2026-22172GHSA-rqpp-rjj8-7wv8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.11
    Fixed in
    2026.3.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-22172: 0.57% estimated exploitation activity in the next 30 days; percentile 47.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A logic flaw in the OpenClaw gateway WebSocket connect path allowed certain device-less shared-token or password-authenticated backend connections to keep client-declared scopes without server-side binding. A shared-authenticated client could present elevated scopes such as operator.admin even though those scopes were not tied to a device identity or an explicitly trusted Control UI path. Impact This crossed the intended authorization boundary and could let a shared-secret-authenticated backend client perform admin-only gateway operations. Affected versions openclaw <= 2026.3.11 Patch Fixed in openclaw 2026.3.12. The gateway now clears unbound scopes for non-Control-UI shared-auth connections, and regression tests cover the device-less shared-auth path.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rqpp-rjj8-7wv8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rqpp-rjj8-7wv8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rqpp-rjj8-7wv8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22172

Advisory: OpenClaw: WebSocket shared-auth connections could self-declare elevated scopes
IDs: CVE-2026-22172, GHSA-rqpp-rjj8-7wv8
Record: https://patchnext.com/advisories/cve-2026-22172 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.11; fixed in 2026.3.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rqpp-rjj8-7wv8 (GitHub-reviewed advisory GHSA-rqpp-rjj8-7wv8 lists affected ranges: npm openclaw >=0 <=2026.3.11)
- Verified: https://osv.dev/vulnerability/GHSA-rqpp-rjj8-7wv8 (OSV record GHSA-rqpp-rjj8-7wv8 lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…