Skip to content

← Actionable
Medium, CVSS 6.4amended

OpenClaw's non-default safeBins sort configuration can bypass intended allowlist approval constraints

CVE-2026-22169GHSA-vmqr-rc7x-3446

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.22
    Fixed in
    2026.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-22169: 0.21% estimated exploitation activity in the next 30 days; percentile 10.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When sort is explicitly added to tools.exec.safeBins (non-default), the --compress-program option can invoke an external helper and bypass the intended safe-bin approval constraints in allowlist mode. Affected Packages / Versions - Package: openclaw (npm) - Vulnerable versions: <=2026.2.21-2 - Latest published npm version checked during triage: 2026.2.21-2 (as of February 22, 2026) - Patched in planned next release: 2026.2.22 Fix Commit(s) - 57fbbaebca4d34d17549accf6092ae26eb7b605c Release Process Note patchedversions is pre-set to the planned next release (=2026.2.22). Once that npm release is published, the advisory can be published directly. OpenClaw thanks @tdjackey for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vmqr-rc7x-3446

  2. Revision 1 · created ·

    Published from osv record GHSA-vmqr-rc7x-3446

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22169

Advisory: OpenClaw's non-default safeBins sort configuration can bypass intended allowlist approval constraints
IDs: CVE-2026-22169, GHSA-vmqr-rc7x-3446
Record: https://patchnext.com/advisories/cve-2026-22169 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.22; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vmqr-rc7x-3446 (OSV record GHSA-vmqr-rc7x-3446 lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-vmqr-rc7x-3446 (GitHub-reviewed advisory GHSA-vmqr-rc7x-3446 lists affected ranges: npm openclaw >=0 <2026.2.22)

Commands are suggestions: review each one before running it.

Loading voting…