Directus has open redirect in SAML
CVE-2026-22032GHSA-3573-4c68-g8cc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.14.0; @directus/api 32.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 11.14.0
- Fixed in
- 11.14.0
npm @directus/api
- Affected
- < 32.1.1
- Fixed in
- 32.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3573-4c68-g8cc lists affected ranges: npm directus >=0 =0 <32.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3573-4c68-g8cc lists affected ranges: npm directus >=0 =0 <32.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-22032: 0.23% estimated exploitation activity in the next 30 days; percentile 14.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Advisory: Open Redirect in Directus SAML Authentication Summary An open redirect vulnerability exists in the Directus SAML authentication callback endpoint. The RelayState parameter is used in redirects without proper validation against an allowlist of permitted domains. Vulnerability Description During SAML authentication, the RelayState parameter is intended to preserve the user's original destination. However, while the login initiation flow validates redirect targets against allowed domains, this validation is not applied to the callback endpoint. This allows an attacker to craft a malicious authentication request that redirects users to an arbitrary external URL upon completion. The vulnerability is present in both the success and error handling paths of the callback. Impact - Phishing: Users can be redirected to attacker-controlled sites that mimic legitimate login pages - Credential theft: Chained attacks may leverage the redirect to capture OAuth tokens or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3573-4c68-g8cc
- Revision 1 · created ·
Published from osv record GHSA-3573-4c68-g8cc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-22032 Advisory: Directus has open redirect in SAML IDs: CVE-2026-22032, GHSA-3573-4c68-g8cc Record: https://patchnext.com/advisories/cve-2026-22032 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.14.0; @directus/api 32.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 11.14.0; fixed in 11.14.0 - npm @directus/api: affected < 32.1.1; fixed in 32.1.1 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus, @directus/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3573-4c68-g8cc (OSV record GHSA-3573-4c68-g8cc lists affected ranges: npm directus >=0 =0 <32.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3573-4c68-g8cc (GitHub-reviewed advisory GHSA-3573-4c68-g8cc lists affected ranges: npm directus >=0 =0 <32.1.1) Commands are suggestions: review each one before running it.
Loading voting…