Skip to content

← Actionable
Medium, CVSS 6.5amended

React Router has CSRF issue in Action/Server Action Request Processing

CVE-2026-22030GHSA-h5cw-625j-3rxh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.12.0; @remix-run/server-runtime 2.17.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-22030: 0.19% estimated exploitation activity in the next 30 days; percentile 8.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

React Router (or Remix v2) is vulnerable to CSRF attacks on document POST requests to UI routes when using server-side route action handlers in Framework Mode, or when using React Server Actions in the new unstable RSC modes. [!NOTE] This does not impact your application if you are using Declarative Mode (<BrowserRouter) or Data Mode (createBrowserRouter/<RouterProvider).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h5cw-625j-3rxh

  2. Revision 1 · created ·

    Published from osv record GHSA-h5cw-625j-3rxh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22030

Advisory: React Router has CSRF issue in Action/Server Action Request Processing
IDs: CVE-2026-22030, GHSA-h5cw-625j-3rxh
Record: https://patchnext.com/advisories/cve-2026-22030 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-router 7.12.0; @remix-run/server-runtime 2.17.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-router: affected >= 7.0.0, <= 7.11.0; fixed in 7.12.0
- npm @remix-run/server-runtime: affected <= 2.17.2; fixed in 2.17.3

## Suggested inspection (read-only)
- `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @remix-run/server-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-router, @remix-run/server-runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h5cw-625j-3rxh (OSV record GHSA-h5cw-625j-3rxh lists affected ranges: npm react-router >=7.0.0 =0 <2.17.3 (fixed))
- Verified: https://github.com/advisories/GHSA-h5cw-625j-3rxh (GitHub-reviewed advisory GHSA-h5cw-625j-3rxh lists affected ranges: npm react-router >=7.0.0 =0 <=2.17.2)

Commands are suggestions: review each one before running it.

Loading voting…