Skip to content

← Actionable
High, CVSS 7.2amended

Preact has JSON VNode Injection issue

CVE-2026-22028GHSA-36hm-qxxp-pg3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (preact 10.28.2, 10.27.3, 10.26.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm preact

    Affected
    >= 10.26.5, < 10.26.10>= 10.27.0, < 10.27.3>= 10.28.0, < 10.28.2
    Fixed in
    10.28.2, 10.27.3, 10.26.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-22028: 0.27% estimated exploitation activity in the next 30 days; percentile 19.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Vulnerability Type: HTML Injection via JSON Type Confusion Affected Versions: Preact 10.26.5 through 10.28.1 Severity: Low to Medium (see below) Who is Impacted? Applications using affected Preact versions are vulnerable if they meet all of the following conditions: 1. Pass unmodified, unsanitized values from user-modifiable data sources (APIs, databases, local storage, etc.) directly into the render tree 2. Assume these values are strings but the data source could return actual JavaScript objects instead of JSON strings 3. The data source either: - Fails to perform type sanitization AND blindly stores/returns raw objects interchangeably with strings, OR - Is compromised (e.g., poisoned local storage, filesystem, or database) Technical Details Preact includes JSON serialization protection to prevent Virtual DOM elements from being constructed from arbitrary JSON. A regression introduced in Preact 10.26.5 caused this protection to be softened. In applications where values from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-36hm-qxxp-pg3m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-36hm-qxxp-pg3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22028

Advisory: Preact has JSON VNode Injection issue
IDs: CVE-2026-22028, GHSA-36hm-qxxp-pg3m
Record: https://patchnext.com/advisories/cve-2026-22028 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: preact 10.28.2, 10.27.3, 10.26.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm preact: affected >= 10.26.5, < 10.26.10; >= 10.27.0, < 10.27.3; >= 10.28.0, < 10.28.2; fixed in 10.28.2, 10.27.3, 10.26.10

## Suggested inspection (read-only)
- `npm ls preact --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on preact.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-36hm-qxxp-pg3m (OSV record GHSA-36hm-qxxp-pg3m lists affected ranges: npm preact >=10.26.5 =10.27.0 =10.28.0 <10.28.2 (fixed))
- Verified: https://github.com/advisories/GHSA-36hm-qxxp-pg3m (GitHub-reviewed advisory GHSA-36hm-qxxp-pg3m lists affected ranges: npm preact >=10.26.5 =10.27.0 =10.28.0 <10.28.2)

Commands are suggestions: review each one before running it.

Loading voting…