Skip to content

← Actionable
Medium, CVSS 6.5amended

n8n's Missing Stripe-Signature Verification Allows Unauthenticated Forged Webhooks

CVE-2026-21894GHSA-jf52-3f2h-h9j5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 0.150.0, < 2.2.2
    Fixed in
    2.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-21894: 0.47% estimated exploitation activity in the next 30 days; percentile 41.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authentication bypass in the Stripe Trigger node allows unauthenticated parties to trigger workflows by sending forged Stripe webhook events. The Stripe Trigger creates and stores a Stripe webhook signing secret when registering the webhook endpoint, but incoming webhook requests were not verified against this secret. As a result, any HTTP client that knows the webhook URL could send a POST request containing a matching event type, causing the workflow to execute as if a legitimate Stripe event had been received. This issue affects n8n users who have active workflows using the Stripe Trigger node. An attacker could potentially fake payment or subscription events and influence downstream workflow behavior. The practical risk is reduced by the fact that the webhook URL contains a high-entropy UUID; however, authenticated n8n users with access to the workflow can view this webhook ID. Patches The issue has been fixed in n8n version 2.2.2. Users should upgrade to this version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jf52-3f2h-h9j5

  2. Revision 1 · created ·

    Published from osv record GHSA-jf52-3f2h-h9j5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21894

Advisory: n8n's Missing Stripe-Signature Verification Allows Unauthenticated Forged Webhooks
IDs: CVE-2026-21894, GHSA-jf52-3f2h-h9j5
Record: https://patchnext.com/advisories/cve-2026-21894 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 0.150.0, < 2.2.2; fixed in 2.2.2

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jf52-3f2h-h9j5 (OSV record GHSA-jf52-3f2h-h9j5 lists affected ranges: npm n8n >=0.150.0 <2.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-jf52-3f2h-h9j5 (GitHub-reviewed advisory GHSA-jf52-3f2h-h9j5 lists affected ranges: npm n8n >=0.150.0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…