n8n Vulnerable to Command Injection in Community Package Installation
CVE-2026-21893GHSA-7c4h-vh2m-743m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.120.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 0.187.0, < 1.120.3
- Fixed in
- 1.120.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7c4h-vh2m-743m lists affected ranges: npm n8n >=0.187.0 <1.120.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7c4h-vh2m-743m lists affected ranges: npm n8n >=0.187.0 <1.120.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-21893: 1.54% estimated exploitation activity in the next 30 days; percentile 74.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Command Injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. Important context - Exploitation requires administrative access to the n8n instance. - The affected functionality is restricted to trusted users who are already permitted to install third-party community packages. - No unauthenticated or low-privilege exploitation is possible. - There is no evidence of exploitation in the wild. Because administrative users can already extend n8n with custom or community code, the vulnerability does not meaningfully expand the threat model beyond existing administrator capabilities. However, it represents a violation of secure coding practices and has therefore been addressed. Patches Users are advised to upgrade to n8n version 1.120.3 or later, which fully resolves the issue. As a general…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-7c4h-vh2m-743m
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-7c4h-vh2m-743m
- Revision 1 · created ·
Published from ghsa record GHSA-7c4h-vh2m-743m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-21893 Advisory: n8n Vulnerable to Command Injection in Community Package Installation IDs: CVE-2026-21893, GHSA-7c4h-vh2m-743m Record: https://patchnext.com/advisories/cve-2026-21893 (revision 4, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 1.120.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 0.187.0, < 1.120.3; fixed in 1.120.3 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7c4h-vh2m-743m (GitHub-reviewed advisory GHSA-7c4h-vh2m-743m lists affected ranges: npm n8n >=0.187.0 <1.120.3) - Verified: https://osv.dev/vulnerability/GHSA-7c4h-vh2m-743m (OSV record GHSA-7c4h-vh2m-743m lists affected ranges: npm n8n >=0.187.0 <1.120.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…