Skip to content

← Actionable
Critical, CVSS 9.9amended

n8n Vulnerable to RCE via Arbitrary File Write

CVE-2026-21877GHSA-v364-rw7m-3263

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.121.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 0.123.0, < 1.121.3
    Fixed in
    1.121.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-21877: 5.45% estimated exploitation activity in the next 30 days; percentile 92.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact n8n is affected by an authenticated Remote Code Execution (RCE) vulnerability. Under certain conditions, an authenticated user may be able to cause untrusted code to be executed by the n8n service. This could result in full compromise of the affected instance. Both self-hosted and n8n Cloud instances are impacted. Patches The issue has been resolved in n8n version 1.121.3. Users are advised to upgrade to this version or later to fully address the vulnerability. Workarounds If upgrading is not immediately possible, administrators can reduce exposure by disabling the Git node and limiting access for untrusted users. References - n8n documentation: Blocking access to nodes

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v364-rw7m-3263

  2. Revision 2 · amended ·

    Amended from osv record GHSA-v364-rw7m-3263

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v364-rw7m-3263

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21877

Advisory: n8n Vulnerable to RCE via Arbitrary File Write
IDs: CVE-2026-21877, GHSA-v364-rw7m-3263
Record: https://patchnext.com/advisories/cve-2026-21877 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.121.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 0.123.0, < 1.121.3; fixed in 1.121.3

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v364-rw7m-3263 (GitHub-reviewed advisory GHSA-v364-rw7m-3263 lists affected ranges: npm n8n >=0.123.0 <1.121.3)
- Verified: https://osv.dev/vulnerability/GHSA-v364-rw7m-3263 (OSV record GHSA-v364-rw7m-3263 lists affected ranges: npm n8n >=0.123.0 <1.121.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…