Skip to content

← Actionable
Medium, CVSS 5.3amended

NiceGUI has Redis connection leak via tab storage causes service degradation

CVE-2026-21874GHSA-mp55-g7pj-rvm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    >= 2.10.0, <= 3.4.1
    Fixed in
    3.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-21874: 0.55% estimated exploitation activity in the next 30 days; percentile 46.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can exhaust Redis connections by repeatedly opening and closing browser tabs on any NiceGUI application using Redis-backed storage. Connections are never released, leading to service degradation when Redis hits its connection limit. NiceGUI continues accepting new connections - errors are logged but the app stays up with broken storage functionality. Details When a client disconnects, tabid is cleared at https://github.com/zauberzeug/nicegui/blob/main/nicegui/client.py#L307 before delete() is called at https://github.com/zauberzeug/nicegui/blob/main/nicegui/client.py#L319. By then tabid is None, so there's no way to find the RedisPersistentDict and call https://github.com/zauberzeug/nicegui/blob/main/nicegui/persistence/redispersistentdict.py#L92. Each tab creates a RedisPersistentDict with a Redis client connection and a pubsub subscription. These are never closed, accumulating until Redis maxclients is reached. PoC Test server…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mp55-g7pj-rvm2

  2. Revision 1 · created ·

    Published from osv record GHSA-mp55-g7pj-rvm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21874

Advisory: NiceGUI has Redis connection leak via tab storage causes service degradation
IDs: CVE-2026-21874, GHSA-mp55-g7pj-rvm2
Record: https://patchnext.com/advisories/cve-2026-21874 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected >= 2.10.0, <= 3.4.1; fixed in 3.5.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mp55-g7pj-rvm2 (OSV record GHSA-mp55-g7pj-rvm2 lists affected ranges: PyPI nicegui >=2.10.0 <3.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mp55-g7pj-rvm2 (GitHub-reviewed advisory GHSA-mp55-g7pj-rvm2 lists affected ranges: PyPI nicegui >=2.10.0 <=3.4.1)

Commands are suggestions: review each one before running it.

Loading voting…