Skip to content

← Actionable
High, CVSS 7.2amended

NiceGUI apps which use ui.sub_pages vulnerable to zero-click XSS

CVE-2026-21873GHSA-mhpg-c27v-6mxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    >= 2.22.0, <= 3.4.1
    Fixed in
    3.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-21873: 0.26% estimated exploitation activity in the next 30 days; percentile 17.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsafe implementation in the pushstate event listener used by ui.subpages allows an attacker to manipulate the fragment identifier of the URL, which they can do despite being cross-site, using an iframe. Details The problem is traced as follows: 1. On pushstate, handleStateEvent is executed. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/elements/subpages.js#L38-L39 2. handleStateEvent emits subpagesopen event. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/elements/subpages.js#L22-L25 3. SubPagesRouter (used by ui.subpages), lisnening on subpagesopen, handleopen runs. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/subpagesrouter.py#L18-L22 4. handleopen finds any SubPages and runs show() on them https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/subpagesrouter.py#L63-L71 5. If the if-logic is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mhpg-c27v-6mxr

  2. Revision 1 · created ·

    Published from osv record GHSA-mhpg-c27v-6mxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21873

Advisory: NiceGUI apps which use `ui.sub_pages` vulnerable to zero-click XSS
IDs: CVE-2026-21873, GHSA-mhpg-c27v-6mxr
Record: https://patchnext.com/advisories/cve-2026-21873 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected >= 2.22.0, <= 3.4.1; fixed in 3.5.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhpg-c27v-6mxr (OSV record GHSA-mhpg-c27v-6mxr lists affected ranges: PyPI nicegui >=2.22.0 <3.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mhpg-c27v-6mxr (GitHub-reviewed advisory GHSA-mhpg-c27v-6mxr lists affected ranges: PyPI nicegui >=2.22.0 <=3.4.1)

Commands are suggestions: review each one before running it.

Loading voting…