Skip to content

← Actionable
Medium, CVSS 6.1amended

NiceGUI apps are vulnerable to XSS which uses ui.sub_pages and render arbitrary user-provided links

CVE-2026-21872GHSA-m7j5-rq9j-6jj9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    >= 2.22.0, <= 3.4.1
    Fixed in
    3.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-21872: 0.27% estimated exploitation activity in the next 30 days; percentile 19.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsafe implementation in the click event listener used by ui.subpages, combined with attacker-controlled link rendering on the page, causes an XSS when the user actively clicks on the link. Details 1. On click, eventually subpagesnavigate event is emitted. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/elements/subpages.js#L41-L63 2. SubPagesRouter (used by ui.subpages), lisnening on subpagesnavigate, handlenavigate runs. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/subpagesrouter.py#L18-L22 3. handlenavigate runs runjavascript with f-string substituting self.currentpath which is simply surrounded by double-quotes. The string context can be broken out easily. https://github.com/zauberzeug/nicegui/blob/59fa9424c470f1b12c5d368985fa36e21fda706b/nicegui/subpagesrouter.py#L73-L88 PoC The minimal PoC boils down to this: However, it is more likely that the attack takes place with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m7j5-rq9j-6jj9

  2. Revision 1 · created ·

    Published from osv record GHSA-m7j5-rq9j-6jj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21872

Advisory: NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links
IDs: CVE-2026-21872, GHSA-m7j5-rq9j-6jj9
Record: https://patchnext.com/advisories/cve-2026-21872 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected >= 2.22.0, <= 3.4.1; fixed in 3.5.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m7j5-rq9j-6jj9 (OSV record GHSA-m7j5-rq9j-6jj9 lists affected ranges: PyPI nicegui >=2.22.0 <3.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m7j5-rq9j-6jj9 (GitHub-reviewed advisory GHSA-m7j5-rq9j-6jj9 lists affected ranges: PyPI nicegui >=2.22.0 <=3.4.1)

Commands are suggestions: review each one before running it.

Loading voting…