Skip to content

← Actionable
Medium, CVSS 6.1amended

NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()

CVE-2026-21871GHSA-7grm-h62g-5m97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    >= 2.13.0, <= 3.4.1
    Fixed in
    3.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-21871: 0.27% estimated exploitation activity in the next 30 days; percentile 19.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary XSS risk exists in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. Details NiceGUI provides ui.navigate.history.push(url) and ui.navigate.history.replace(url) to update the URL using the browser History API. If an application forwards user-controlled data (e.g., URL path segments, query parameters like next=..., form values, etc.) into these methods, an attacker can inject characters such as quotes and statement terminators to escape the JavaScript string context and execute arbitrary code. A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7grm-h62g-5m97

  2. Revision 1 · created ·

    Published from osv record GHSA-7grm-h62g-5m97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21871

Advisory: NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()
IDs: CVE-2026-21871, GHSA-7grm-h62g-5m97
Record: https://patchnext.com/advisories/cve-2026-21871 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected >= 2.13.0, <= 3.4.1; fixed in 3.5.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7grm-h62g-5m97 (OSV record GHSA-7grm-h62g-5m97 lists affected ranges: PyPI nicegui >=2.13.0 <3.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7grm-h62g-5m97 (GitHub-reviewed advisory GHSA-7grm-h62g-5m97 lists affected ranges: PyPI nicegui >=2.13.0 <=3.4.1)

Commands are suggestions: review each one before running it.

Loading voting…