Skip to content

← Actionable
Critical, CVSS 10.0amended

n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling

CVE-2026-21858GHSA-v4pr-fm98-w9pg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.121.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 1.65.0, < 1.121.0
    Fixed in
    1.121.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-21858: 78.19% estimated exploitation activity in the next 30 days; percentile 99.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in n8n allows an attacker to access files on the underlying server through execution of certain form-based workflows. A vulnerable workflow could grant access to an unauthenticated remote attacker. This could result in exposure of sensitive information stored on the system and may enable further compromise depending on deployment configuration and workflow usage. Patches The issue has been fixed in n8n version 1.121.0. Users should upgrade to this version or later to remediate the vulnerability. Workarounds No official workarounds are available. As a temporary mitigation, users may restrict or disable publicly accessible webhook and form endpoints until upgrading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v4pr-fm98-w9pg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-v4pr-fm98-w9pg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v4pr-fm98-w9pg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21858

Advisory: n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
IDs: CVE-2026-21858, GHSA-v4pr-fm98-w9pg
Record: https://patchnext.com/advisories/cve-2026-21858 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.121.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 1.65.0, < 1.121.0; fixed in 1.121.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v4pr-fm98-w9pg (GitHub-reviewed advisory GHSA-v4pr-fm98-w9pg lists affected ranges: npm n8n >=1.65.0 <1.121.0)
- Verified: https://osv.dev/vulnerability/GHSA-v4pr-fm98-w9pg (OSV record GHSA-v4pr-fm98-w9pg lists affected ranges: npm n8n >=1.65.0 <1.121.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…