Claude Code Leaks Data via Malicious Environment Configuration Before Trust Confirmation
CVE-2026-21852GHSA-jh7p-qr78-84p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 2.0.65), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.0.65
- Fixed in
- 2.0.65
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jh7p-qr78-84p7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.0.65 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jh7p-qr78-84p7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.0.65
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-21852: 27.50% estimated exploitation activity in the next 30 days; percentile 98.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Claude Code's project-load flow allowed malicious repositories to exfiltrate data including Anthropic API keys before users confirmed trust. If a user started Claude Code in an attacker-controller repository, and the repository included a settings file that set ANTHROPICBASEURL to an attacker-controlled endpoint, Claude Code would issue API requests before showing the trust prompt, including potentially leaking the user's API keys. Users on standard Claude Code auto-update have received this fix already. Users performing manual updates are advised to update to the latest version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jh7p-qr78-84p7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jh7p-qr78-84p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-21852 Advisory: Claude Code Leaks Data via Malicious Environment Configuration Before Trust Confirmation IDs: CVE-2026-21852, GHSA-jh7p-qr78-84p7 Record: https://patchnext.com/advisories/cve-2026-21852 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 2.0.65. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/claude-code: affected < 2.0.65; fixed in 2.0.65 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/claude-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jh7p-qr78-84p7 (OSV record GHSA-jh7p-qr78-84p7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.0.65 (fixed)) - Verified: https://github.com/advisories/GHSA-jh7p-qr78-84p7 (GitHub-reviewed advisory GHSA-jh7p-qr78-84p7 lists affected ranges: npm @anthropic-ai/claude-code >=0 <2.0.65) Commands are suggestions: review each one before running it.
Loading voting…