Skip to content

← Actionable
Medium, CVSS 5.3amended

MONAI has Path Traversal (Zip Slip) in NGC Private Bundle Download

CVE-2026-21851GHSA-9rg3-9pvr-6p27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (monai 1.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI monai

    Affected
    <= 1.5.1
    Fixed in
    1.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-21851: 0.36% estimated exploitation activity in the next 30 days; percentile 29.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Path Traversal (Zip Slip) vulnerability exists in MONAI's downloadfromngcprivate() function. The function uses zipfile.ZipFile.extractall() without path validation, while other similar download functions in the same codebase properly use the existing safeextractmember() function. This appears to be an implementation oversight, as safe extraction is already implemented and used elsewhere in MONAI. CWE: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory) --- Details Vulnerable Code Location File: monai/bundle/scripts.py Lines: 291-292 Function: downloadfromngcprivate() Root Cause The code calls z.extractall(extractpath) directly without validating that archive member paths stay within the extraction directory. Safe Code Already Exists MONAI already has a safe extraction function in monai/apps/utils.py (lines 125-154) that properly validates paths: Comparison with Other Download Functions | Function | File | Uses Safe Extraction? |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9rg3-9pvr-6p27

  2. Revision 1 · created ·

    Published from osv record GHSA-9rg3-9pvr-6p27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21851

Advisory: MONAI has Path Traversal (Zip Slip) in NGC Private Bundle Download
IDs: CVE-2026-21851, GHSA-9rg3-9pvr-6p27
Record: https://patchnext.com/advisories/cve-2026-21851 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: monai 1.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI monai: affected <= 1.5.1; fixed in 1.5.2

## Suggested inspection (read-only)
- `python -m pip show monai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on monai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9rg3-9pvr-6p27 (OSV record GHSA-9rg3-9pvr-6p27 lists affected ranges: PyPI monai >=0 <1.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9rg3-9pvr-6p27 (GitHub-reviewed advisory GHSA-9rg3-9pvr-6p27 lists affected ranges: PyPI monai >=0 <=1.5.1)

Commands are suggestions: review each one before running it.

Loading voting…