Incomplete fix for CVE-2026-21637: loadSNI() in _tls_wrap.js lacks try/catch leading to Remote DoS
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 25.8.2, 24.14.1, 22.22.2, 20.20.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 20.0.0, < 20.20.2>= 22.0.0, < 22.22.2>= 24.0.0, < 24.14.1>= 25.0.0, < 25.8.2
- Fixed in
- 24.14.1, 20.20.2, 25.8.2, 22.22.2
Sources
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 163 lists CVE-2026-21637 affecting node >=20.0.0 =22.0.0 =24.0.0 =25.0.0 <25.8.2
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2026-21637 to 2026-03-24.
VerifiedObserved Official nodejs.org release index (dist/index.json).
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-21637: 1.12% estimated exploitation activity in the next 30 days; percentile 66.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw in Node.js TLS error handling leaves `SNICallback` invocations unprotected against synchronous exceptions, while the equivalent ALPN and PSK callbacks were already addressed in CVE-2026-21637. This represents an incomplete fix of that prior vulnerability. When an `SNICallback` throws synchronously on unexpected input the exception bypasses TLS error handlers and propagates as an uncaught exception, crashing the Node.js process. * This vulnerability affects all Node.js versions that received the CVE-2026-21637 fix, including 20.x, 22.x, 24.x, and 25.x, on any TLS server where `SNICallback` may throw on unexpected `servername` input.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:163
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:163
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-21637 Advisory: Incomplete fix for CVE-2026-21637: loadSNI() in _tls_wrap.js lacks try/catch leading to Remote DoS IDs: CVE-2026-21637 Record: https://patchnext.com/advisories/cve-2026-21637 (revision 2, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 25.8.2, 24.14.1, 22.22.2, 20.20.2. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 20.0.0, < 20.20.2; >= 22.0.0, < 22.22.2; >= 24.0.0, < 24.14.1; >= 25.0.0, < 25.8.2; fixed in 24.14.1, 20.20.2, 25.8.2, 22.22.2 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/163.json (Node.js security working group core entry 163 lists CVE-2026-21637 affecting node >=20.0.0 =22.0.0 =24.0.0 =25.0.0 <25.8.2) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-21637 to 2026-03-24.) Commands are suggestions: review each one before running it.
Loading voting…