Skip to content

← Actionable
Medium, CVSS 5.4

listmonk Vulnerable to Stored XSS Leading to Admin Account Takeover

CVE-2026-21483GHSA-jmr4-p576-v565

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/knadh/listmonk 6.0.0, 1.1.1-0.20251231125615-74dc5a01cfbb), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/knadh/listmonk

    Affected
    >= 1.1.1, < 6.0.0< 1.1.1-0.20251231125615-74dc5a01cfbb
    Fixed in
    6.0.0, 1.1.1-0.20251231125615-74dc5a01cfbb

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P · score source
EPSS
  • CVE-2026-21483: 0.23% estimated exploitation activity in the next 30 days; percentile 13.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: Stored XSS Leading to Admin Account Takeover Affected Versions: ≤ 5.1.0 Vulnerability Type: CWE-79: Stored Cross-Site Scripting --- Summary A lower-privileged user with campaign management permissions can inject malicious JavaScript into campaigns or templates. When a higher-privileged user (Super Admin) views or previews this content, the XSS executes in their browser context, allowing the attacker to perform privileged actions such as creating backdoor admin accounts. The attack can be weaponized via the public archive feature, where victims simply need to visit a link - no preview click required. --- Required Attacker Permissions Note: These are common permissions for content managers who are not full admins. --- Attack Vectors Vector 1: Raw HTML (Direct Script Tag) Vector 2: Go Template Safe Function --- Attack Scenarios Scenario 1: Campaign Preview Attack 1. Attacker creates campaign with XSS payload 2. Request is made to super admin: "Please review my…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jmr4-p576-v565

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21483

Advisory: listmonk Vulnerable to Stored XSS Leading to Admin Account Takeover
IDs: CVE-2026-21483, GHSA-jmr4-p576-v565
Record: https://patchnext.com/advisories/cve-2026-21483 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/knadh/listmonk 6.0.0, 1.1.1-0.20251231125615-74dc5a01cfbb. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/knadh/listmonk: affected >= 1.1.1, < 6.0.0; < 1.1.1-0.20251231125615-74dc5a01cfbb; fixed in 6.0.0, 1.1.1-0.20251231125615-74dc5a01cfbb

## Suggested inspection (read-only)
- Go github.com/knadh/listmonk: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/knadh/listmonk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jmr4-p576-v565 (GitHub-reviewed advisory GHSA-jmr4-p576-v565 lists affected ranges: Go github.com/knadh/listmonk >=1.1.1 =0 <1.1.1-0.20251231125615-74dc5a01cfbb)

Commands are suggestions: review each one before running it.

Loading voting…