Skip to content

← Actionable
High, CVSS 8.8

Bagisto Missing Authentication on Installer API Endpoints

CVE-2026-21446GHSA-6h7w-v2xr-mqvw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bagisto/bagisto 2.3.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-21446: 0.63% estimated exploitation activity in the next 30 days; percentile 50.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerable Code File: packages/Ibkul/Installer/src/Routes/Ib.php API routes remain active even after initial installation is complete, allowing any unauthenticated attacker to: - Create admin accounts - Modify application configuration - Potentially overwrite existing data the underlying API endpoints (/install/api/) are directly accessible and exploitable without any authentication. An attacker can bypass the Ib installer entirely by calling the API endpoints directly. How to Reproduce 1. The Ib installer UI at http://localhost:8000/install has client-side protections 2. However, the API endpoints are directly exploitable: - The attack works by calling /install/api/admin-config-setup directly via curl/HTTP client - No CSRF token, session, or authentication is required - The Ib UI workflow is completely bypassed Proof of Concept Expected Result The API should reject unauthenticated requests with 401/403 status. Actual Result The API accepts the request and creates a new admin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6h7w-v2xr-mqvw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21446

Advisory: Bagisto Missing Authentication on Installer API Endpoints
IDs: CVE-2026-21446, GHSA-6h7w-v2xr-mqvw
Record: https://patchnext.com/advisories/cve-2026-21446 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bagisto/bagisto 2.3.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bagisto/bagisto: affected >= 2.3.0, < 2.3.10; fixed in 2.3.10

## Suggested inspection (read-only)
- Packagist bagisto/bagisto: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bagisto/bagisto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6h7w-v2xr-mqvw (GitHub-reviewed advisory GHSA-6h7w-v2xr-mqvw lists affected ranges: Packagist bagisto/bagisto >=2.3.0 <2.3.10)

Commands are suggestions: review each one before running it.

Loading voting…