Skip to content

← Actionable
High, CVSS 8.8amended

Langflow Missing Authentication on Critical API Endpoints

CVE-2026-21445GHSA-c5cp-vx83-jhqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow-base 0.7.1; langflow 1.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-21445: 33.29% estimated exploitation activity in the next 30 days; percentile 98.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple critical API endpoints in Langflow are missing authentication controls, allowing any unauthenticated user to access sensitive user conversation data, transaction histories, and perform destructive operations including message deletion. This affects endpoints handling personal data and system operations that should require proper authorization. Details The vulnerability exists in three API endpoints within src/backend/base/langflow/api/v1/monitor.py that are missing the required dependencies=[Depends(getcurrentactiveuser)] authentication dependency: Affected Endpoints: 1. GET /api/v1/monitor/messages (Line 61) 2. GET /api/v1/monitor/transactions (Line 183) 3. DELETE /api/v1/monitor/messages/session/{sessionid} (Line 165) Inconsistency Evidence: Other endpoints in the same file properly implement authentication: PoC Complete reproduction steps to demonstrate the vulnerability: Prerequisites: 1. Start a Langflow server instance 2. Ensure no authentication headers or API…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c5cp-vx83-jhqx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c5cp-vx83-jhqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21445

Advisory: Langflow Missing Authentication on Critical API Endpoints
IDs: CVE-2026-21445, GHSA-c5cp-vx83-jhqx
Record: https://patchnext.com/advisories/cve-2026-21445 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow-base 0.7.1; langflow 1.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow-base: affected <= 0.6.9; fixed in 0.7.1
- PyPI langflow: affected <= 1.7.0.dev44; fixed in 1.7.1

## Suggested inspection (read-only)
- `python -m pip show langflow-base`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow-base, langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c5cp-vx83-jhqx (OSV record GHSA-c5cp-vx83-jhqx lists affected ranges: PyPI langflow-base >=0 =0 <1.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c5cp-vx83-jhqx (GitHub-reviewed advisory GHSA-c5cp-vx83-jhqx lists affected ranges: PyPI langflow-base >=0 =0 <=1.7.0.dev44)

Commands are suggestions: review each one before running it.

Loading voting…