Skip to content

← Actionable
Medium, CVSS 4.2amended

podman quadlet install --replace does not fully replace the old file

CVE-2026-19730GHSA-fx76-2j3w-2mx6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/containers/podman/v5

    Affected
    >= 5.7.0, < 5.8.6
    Fixed in
    5.8.6
  • Go github.com/containers/podman/v3

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman/v2

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman/v4

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-19730: 0.13% estimated exploitation activity in the next 30 days; percentile 2.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When running podman quadlet install --replace to replace a Quadlet file, if the original Quadlet is larger than the new Quadlet, the file would not be truncated and content from the original would be preserved. There is no risk of information leakage as the user already had access to the Quadlet in order to replace it, and in most cases, this would only lead to invalid Quadlet files (see https://github.com/podman-container-tools/podman/issues/29013). However, security-related options from the end of the old Quadlet could be included in the new Quadlet, and if the truncation resulted in a valid Quadlet file, this could result in undesirable behavior. For example, running podman quadlet install --replace to remove a single line from the end of a Quadlet - including security-sensitive content, like AddCapability - will fail, and the option will continue to be used. Further, with Volume Quadlets, this can include additional mounts which can cause content to be unintentionally…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fx76-2j3w-2mx6

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6588

  3. Revision 1 · created ·

    Published from osv record GHSA-fx76-2j3w-2mx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-19730

Advisory: podman quadlet install --replace does not fully replace the old file
IDs: CVE-2026-19730, GHSA-fx76-2j3w-2mx6
Record: https://patchnext.com/advisories/cve-2026-19730 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/containers/podman/v5 5.8.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containers/podman/v5: affected >= 5.7.0, < 5.8.6; fixed in 5.8.6
- Go github.com/containers/podman/v3: affected every version
- Go github.com/containers/podman: affected every version
- Go github.com/containers/podman/v2: affected every version
- Go github.com/containers/podman/v4: affected every version

## Suggested inspection (read-only)
- Go github.com/containers/podman/v5: check the installed version with your package manager.
- Go github.com/containers/podman/v3: check the installed version with your package manager.
- Go github.com/containers/podman: check the installed version with your package manager.
- Go github.com/containers/podman/v2: check the installed version with your package manager.
- Go github.com/containers/podman/v4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containers/podman/v5, github.com/containers/podman/v3, github.com/containers/podman, github.com/containers/podman/v2, github.com/containers/podman/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6588 (OSV record GO-2026-6588 lists affected ranges: Go github.com/containers/podman >=0; Go github.com/containers/podman/v2 >=0; Go github.com/containers/podman/v3 >=0; Go github.com/containers/podman/v4 >=0; Go github.com/containers/podman/v5 >=5.7.0 <5.8.6 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-fx76-2j3w-2mx6 (OSV record GHSA-fx76-2j3w-2mx6 lists affected ranges: Go github.com/containers/podman/v5 >=5.7.0 <5.8.6 (fixed))
- Verified: https://github.com/advisories/GHSA-fx76-2j3w-2mx6 (GitHub-reviewed advisory GHSA-fx76-2j3w-2mx6 lists affected ranges: Go github.com/containers/podman/v5 >=5.7.0 <5.8.6)

Commands are suggestions: review each one before running it.

Loading voting…