undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
CVE-2026-19534GHSA-rfgv-xxqx-mfg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.10.2, 7.29.1, 6.28.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 6.7.0, < 6.28.1>= 7.0.0, < 7.29.1>= 8.0.0, < 8.10.2
- Fixed in
- 7.29.1, 8.10.2, 6.28.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfgv-xxqx-mfg5 lists affected ranges: npm undici >=6.7.0 =7.0.0 =8.0.0 <8.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rfgv-xxqx-mfg5 lists affected ranges: npm undici >=6.7.0 =7.0.0 =8.0.0 <8.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-19534: 0.39% estimated exploitation activity in the next 30 days; percentile 33.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The undici WebSocket client throws an uncaught TypeError during the opening handshake when a server's 101 response includes a Sec-WebSocket-Protocol header that the client never requested. The throw occurs in a queueMicrotask callback with no surrounding try/catch, so it propagates as an uncaught exception and terminates the Node.js process. This is a remote, unauthenticated denial of service against any application that opens a WebSocket to an attacker controlled or compromised server, or over a plaintext ws:// connection subject to a machine-in-the-middle. It affects the default new WebSocket(url) usage, where no subprotocol is requested. Per RFC 6455 section 4.1, an unrequested subprotocol must fail the connection, not crash it. All releases starting at undici 6.7.0 are affected. Patches Upgrade to undici 6.28.1, 7.29.1, or 8.10.2. Workarounds No workaround is available. The fix must be applied through an upgrade.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rfgv-xxqx-mfg5
- Revision 2 · amended ·
Amended from osv record GHSA-rfgv-xxqx-mfg5
- Revision 1 · created ·
Published from ghsa record GHSA-rfgv-xxqx-mfg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-19534 Advisory: undici vulnerable to Denial of Service via unrequested WebSocket subprotocol IDs: CVE-2026-19534, GHSA-rfgv-xxqx-mfg5 Record: https://patchnext.com/advisories/cve-2026-19534 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.10.2, 7.29.1, 6.28.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 6.7.0, < 6.28.1; >= 7.0.0, < 7.29.1; >= 8.0.0, < 8.10.2; fixed in 7.29.1, 8.10.2, 6.28.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfgv-xxqx-mfg5 (GitHub-reviewed advisory GHSA-rfgv-xxqx-mfg5 lists affected ranges: npm undici >=6.7.0 =7.0.0 =8.0.0 <8.10.2) - Verified: https://osv.dev/vulnerability/GHSA-rfgv-xxqx-mfg5 (OSV record GHSA-rfgv-xxqx-mfg5 lists affected ranges: npm undici >=6.7.0 =7.0.0 =8.0.0 <8.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…