Skip to content

← Actionable
High, CVSS 7.5amended

@fastify/busboy vulnerable to Denial of Service via oversized multipart boundary

CVE-2026-19484GHSA-xjh9-v7x6-24jw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/busboy 3.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-19484: 0.61% estimated exploitation activity in the next 30 days; percentile 49.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions of @fastify/busboy from 3.1.0 and prior to 3.2.1 are vulnerable to a Denial of Service. The vendored streaming multipart search stores its default skip distance in a Uint8Array(256). A multipart boundary of exactly 252 bytes makes the search needle 256 bytes, and the table entry wraps to zero, so a crafted request keeps the search in a CPU-bound loop and stalls the Node.js event loop. An unauthenticated client can trigger this with a single small request. Applications that use @fastify/busboy to parse multipart/form-data, directly or through @fastify/multipart, are affected. Patches Fixed in version 3.2.1. Workarounds Validate the multipart boundary before parsing and reject any boundary longer than the RFC 2046 limit of 70 characters (for example at a reverse proxy or in an onRequest hook). Upgrading to 3.2.1 removes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xjh9-v7x6-24jw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xjh9-v7x6-24jw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xjh9-v7x6-24jw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-19484

Advisory: @fastify/busboy vulnerable to Denial of Service via oversized multipart boundary
IDs: CVE-2026-19484, GHSA-xjh9-v7x6-24jw
Record: https://patchnext.com/advisories/cve-2026-19484 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/busboy 3.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/busboy: affected >= 3.1.0, < 3.2.1; fixed in 3.2.1

## Suggested inspection (read-only)
- `npm ls @fastify/busboy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/busboy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xjh9-v7x6-24jw (GitHub-reviewed advisory GHSA-xjh9-v7x6-24jw lists affected ranges: npm @fastify/busboy >=3.1.0 <3.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-xjh9-v7x6-24jw (OSV record GHSA-xjh9-v7x6-24jw lists affected ranges: npm @fastify/busboy >=3.1.0 <3.2.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…