Skip to content

← Actionable
High, CVSS 7.5amended

@fastify/busboy vulnerable to Denial of Service via prototype-named multipart part header

CVE-2026-19481GHSA-x8mw-p69m-v3mx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/busboy 3.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-19481: 0.49% estimated exploitation activity in the next 30 days; percentile 42.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions of @fastify/busboy from 1.0.0 and prior to 3.2.1 are vulnerable to a Denial of Service. The multipart header parser stores part-header names on a plain JavaScript object, so a part header named proto or constructor resolves to an inherited value that is not an array, and the parser throws TypeError: this.header[h].push is not a function. Through the documented req.pipe(busboy) integration this surfaces as an error event, while direct write()/end() usage throws synchronously and can terminate the Node.js process if uncaught. The parser runs before application middleware, so any unauthenticated client that can submit multipart/form-data is affected. Patches Fixed in version 3.2.1. Workarounds Attach an error listener to the Busboy stream so the parser failure is handled rather than crashing the process, and wrap direct write()/end() calls in a try/catch. Upgrading to 3.2.1 removes the failure entirely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x8mw-p69m-v3mx

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x8mw-p69m-v3mx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x8mw-p69m-v3mx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-19481

Advisory: @fastify/busboy vulnerable to Denial of Service via prototype-named multipart part header
IDs: CVE-2026-19481, GHSA-x8mw-p69m-v3mx
Record: https://patchnext.com/advisories/cve-2026-19481 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/busboy 3.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/busboy: affected >= 1.0.0, < 3.2.1; fixed in 3.2.1

## Suggested inspection (read-only)
- `npm ls @fastify/busboy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/busboy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x8mw-p69m-v3mx (GitHub-reviewed advisory GHSA-x8mw-p69m-v3mx lists affected ranges: npm @fastify/busboy >=1.0.0 <3.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-x8mw-p69m-v3mx (OSV record GHSA-x8mw-p69m-v3mx lists affected ranges: npm @fastify/busboy >=1.0.0 <3.2.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…