fast-uri vulnerable to host confusion via backslash authority introducer
CVE-2026-18446GHSA-7p8r-x3mc-p8w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.2, 3.1.5, 2.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- < 2.4.4>= 3.0.0, < 3.1.5>= 4.0.0, < 4.1.2
- Fixed in
- 3.1.5, 4.1.2, 2.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p8r-x3mc-p8w7 lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-18446: 0.38% estimated exploitation activity in the next 30 days; percentile 32.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri v4.1.1 and earlier require a literal // to recognize a URI authority, so a reference that uses \\, /\, or \/ as the authority introducer (in place of //, after an optional scheme) is parsed with no authority: the sequence and everything after it fold into the path. Node's native WHATWG URL (used by fetch(), undici, and Node's http/https clients) instead treats \ as interchangeable with / for special schemes (http, https, ws, wss, ftp, file), so the two parsers extract different hosts from the same input. For example, fast-uri resolves \\evil.com/path against base https://allowed.com/ to https://allowed.com/%5C%5Cevil.com/path (confined to the trusted host), while Node's WHATWG URL resolves the same reference to https://evil.com/path. Applications that use fast-uri to enforce host-based policy (allowlists, denylists, loopback/SSRF filtering, redirect validation, outbound proxy routing) before passing the same URL into Node's URL or fetch() consumers see a policy/use…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7p8r-x3mc-p8w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-18446 Advisory: fast-uri vulnerable to host confusion via backslash authority introducer IDs: CVE-2026-18446, GHSA-7p8r-x3mc-p8w7 Record: https://patchnext.com/advisories/cve-2026-18446 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.2, 3.1.5, 2.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected < 2.4.4; >= 3.0.0, < 3.1.5; >= 4.0.0, < 4.1.2; fixed in 3.1.5, 4.1.2, 2.4.4 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7p8r-x3mc-p8w7 (GitHub-reviewed advisory GHSA-7p8r-x3mc-p8w7 lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.1.2) Commands are suggestions: review each one before running it.
Loading voting…