Skip to content

← Actionable
High, CVSS 8.7amended

SageMaker Python SDK has Exposed HMAC

CVE-2026-1777GHSA-rjrp-m2jw-pv9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sagemaker 3.2.0, 2.256.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sagemaker

    Affected
    >= 3.0, < 3.2.0< 2.256.0
    Fixed in
    3.2.0, 2.256.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-1777: 0.51% estimated exploitation activity in the next 30 days; percentile 43.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SageMaker Python SDK is an open source library for training and deploying machine learning models on Amazon SageMaker. An issue where the HMAC secret key is stored in environment variables and disclosed via the DescribeTrainingJob API has been identified. Impact - Function and Payload Tampering: Attackers with DescribeTrainingJob permissions may extract HMAC secret keys and forge serialized function payloads stored in S3. These tampered payloads would be processed and executed without triggering integrity validation errors, enabling unintended code substitution. - Arbitrary Code Execution in the Training Environment: An third party with both DescribeTrainingJob permissions and write access to the job's S3 output location can extract the HMAC key, craft inappropriate Python objects, and achieve remote code execution in the client's Python process when the victim retrieves remote function results. - Data and Credentials Handling: Arbitrary remote code execution may interact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rjrp-m2jw-pv9c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rjrp-m2jw-pv9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-1777

Advisory: SageMaker Python SDK has Exposed HMAC
IDs: CVE-2026-1777, GHSA-rjrp-m2jw-pv9c
Record: https://patchnext.com/advisories/cve-2026-1777 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sagemaker 3.2.0, 2.256.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sagemaker: affected >= 3.0, < 3.2.0; < 2.256.0; fixed in 3.2.0, 2.256.0

## Suggested inspection (read-only)
- `python -m pip show sagemaker`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sagemaker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjrp-m2jw-pv9c (OSV record GHSA-rjrp-m2jw-pv9c lists affected ranges: PyPI sagemaker >=3.0 =0 <2.256.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rjrp-m2jw-pv9c (GitHub-reviewed advisory GHSA-rjrp-m2jw-pv9c lists affected ranges: PyPI sagemaker >=3.0 =0 <2.256.0)

Commands are suggestions: review each one before running it.

Loading voting…