Skip to content

← Actionable
Medium, CVSS 5.9amended

moment vulnerable to Path Traversal via crafted non-string locale name

CVE-2026-17495GHSA-4p3w-j4w9-5jqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moment 2.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm moment

    Affected
    >= 2.29.2, < 2.31.0
    Fixed in
    2.31.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-17495: 0.52% estimated exploitation activity in the next 30 days; percentile 44.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact moment before 2.31.0 is vulnerable to path traversal in moment.locale(). When an application passes a non-string, attacker-influenced value to moment.locale(), a specially crafted object can bypass the locale name validation and cause moment to load a file from an attacker-controlled path. This is a further bypass of the validation added in 2.29.2 for CVE-2022-24785. This affects server-side (npm) users only. Plain string input is not affected: the existing validation correctly rejects strings that contain path separators. Patches This issue is patched in moment 2.31.0. Workarounds Validate that any user-supplied input is a string before passing it to moment.locale().

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4p3w-j4w9-5jqw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4p3w-j4w9-5jqw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4p3w-j4w9-5jqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-17495

Advisory: moment vulnerable to Path Traversal via crafted non-string locale name
IDs: CVE-2026-17495, GHSA-4p3w-j4w9-5jqw
Record: https://patchnext.com/advisories/cve-2026-17495 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moment 2.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm moment: affected >= 2.29.2, < 2.31.0; fixed in 2.31.0

## Suggested inspection (read-only)
- `npm ls moment --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moment.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4p3w-j4w9-5jqw (GitHub-reviewed advisory GHSA-4p3w-j4w9-5jqw lists affected ranges: npm moment >=2.29.2 <2.31.0)
- Verified: https://osv.dev/vulnerability/GHSA-4p3w-j4w9-5jqw (OSV record GHSA-4p3w-j4w9-5jqw lists affected ranges: npm moment >=2.29.2 <2.31.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…