Cloudflare Agents is Vulnerable to Reflected Cross-Site Scripting in the AI Playground's OAuth callback handler
CVE-2026-1721GHSA-cvhv-6xm6-c3v4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (agents 0.3.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm agents
- Affected
- < 0.3.10
- Fixed in
- 0.3.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cvhv-6xm6-c3v4 lists affected ranges: npm agents >=0 <0.3.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvhv-6xm6-c3v4 lists affected ranges: npm agents >=0 <0.3.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-1721: 0.42% estimated exploitation activity in the next 30 days; percentile 36.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the AI Playground's OAuth callback handler. The errordescription query parameter was directly interpolated into an HTML script tag without proper escaping, allowing attackers to execute arbitrary JavaScript in the context of the victim's session. Root cause The OAuth callback handler in site/ai-playground/src/server.ts directly interpolated the authError value, sourced from the errordescription query parameter, into an inline <script tag. Impact An attacker could craft a malicious link that, when clicked by a victim, would: Steal user chat message history - Access all LLM interactions stored in the user's session. Access connected MCP Servers - Interact with any MCP servers connected to the victim's session (public or authenticated/private), potentially allowing the attacker to perform actions on the victim's behalf Mitigation: PR: https://github.com/cloudflare/agents/pull/841…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cvhv-6xm6-c3v4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cvhv-6xm6-c3v4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1721 Advisory: Cloudflare Agents is Vulnerable to Reflected Cross-Site Scripting in the AI Playground's OAuth callback handler IDs: CVE-2026-1721, GHSA-cvhv-6xm6-c3v4 Record: https://patchnext.com/advisories/cve-2026-1721 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: agents 0.3.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm agents: affected < 0.3.10; fixed in 0.3.10 ## Suggested inspection (read-only) - `npm ls agents --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on agents. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cvhv-6xm6-c3v4 (OSV record GHSA-cvhv-6xm6-c3v4 lists affected ranges: npm agents >=0 <0.3.10 (fixed)) - Verified: https://github.com/advisories/GHSA-cvhv-6xm6-c3v4 (GitHub-reviewed advisory GHSA-cvhv-6xm6-c3v4 lists affected ranges: npm agents >=0 <0.3.10) Commands are suggestions: review each one before running it.
Loading voting…