Keylime Missing Authentication for Critical Function and Improper Authentication
CVE-2026-1709GHSA-4jqp-9qjv-57m2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keylime 7.13.1, 7.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keylime
- Affected
- >= 7.12.0, < 7.12.2>= 7.13.0, <= 7.13.0
- Fixed in
- 7.12.2, 7.13.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4jqp-9qjv-57m2 lists affected ranges: PyPI keylime >=7.12.0 =7.13.0 <=7.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4jqp-9qjv-57m2 lists affected ranges: PyPI keylime >=7.12.0 =7.13.0 <7.13.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- EPSS
- CVE-2026-1709: 5.71% estimated exploitation activity in the next 30 days; percentile 93.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Keylime registrar does not enforce mutual TLS (mTLS) client certificate authentication since version 7.12.0. The registrar's TLS context is configured with ssl.CERTOPTIONAL instead of ssl.CERTREQUIRED, allowing any client to connect to protected API endpoints without presenting a valid client certificate. Who is impacted: - All Keylime deployments running versions 7.12.0 through 7.13.0 - Environments where the registrar HTTPS port (default 8891) is network-accessible to untrusted clients What an attacker can do: - List all registered agents (GET /v2/agents/) - enumerate the entire agent inventory - Retrieve agent details (GET /v2/agents/{uuid}) - obtain public TPM keys, certificates, and network locations (IP/port) of any agent - Delete any agent (DELETE /v2/agents/{uuid}) - remove agents from the registry, disrupting attestation services Note: The exposed TPM data (EK, AK, certificates) consists of public keys and certificates. Private keys remain protected within TPM…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4jqp-9qjv-57m2
- Revision 2 · amended ·
Amended from osv record GHSA-4jqp-9qjv-57m2
- Revision 1 · created ·
Published from ghsa record GHSA-4jqp-9qjv-57m2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1709 Advisory: Keylime Missing Authentication for Critical Function and Improper Authentication IDs: CVE-2026-1709, GHSA-4jqp-9qjv-57m2 Record: https://patchnext.com/advisories/cve-2026-1709 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keylime 7.13.1, 7.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keylime: affected >= 7.12.0, < 7.12.2; >= 7.13.0, <= 7.13.0; fixed in 7.12.2, 7.13.1 ## Suggested inspection (read-only) - `python -m pip show keylime`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keylime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4jqp-9qjv-57m2 (GitHub-reviewed advisory GHSA-4jqp-9qjv-57m2 lists affected ranges: PyPI keylime >=7.12.0 =7.13.0 <=7.13.0) - Verified: https://osv.dev/vulnerability/GHSA-4jqp-9qjv-57m2 (OSV record GHSA-4jqp-9qjv-57m2 lists affected ranges: PyPI keylime >=7.12.0 =7.13.0 <7.13.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…