undici vulnerable to cookie attribute injection via unsanitized domain and unparsed setCookie fields
CVE-2026-16729GHSA-v3r7-h72x-cjcm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.9.0, 7.29.0, 6.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- < 6.28.0>= 7.0.0, < 7.29.0>= 8.0.0, < 8.9.0
- Fixed in
- 6.28.0, 8.9.0, 7.29.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v3r7-h72x-cjcm lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-16729: 0.28% estimated exploitation activity in the next 30 days; percentile 20.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The setCookie function has two attribute injection paths. validateCookieDomain does not reject semicolons (validateCookiePath already does at 0x3B), so a domain value like example.com; SameSite=None lands verbatim as Domain=example.com; SameSite=None. The unparsed array's loop only checks each entry contains = and does not sanitize values, so an entry like X-Custom=val; HttpOnly lands unchanged, injecting HttpOnly without the caller setting cookie.httpOnly = true. Applications that pass user-controlled input to these fields, typically multi-tenant or reverse-proxy servers that scope session cookies to a tenant-supplied domain, can have SameSite CSRF protections bypassed, Secure or HttpOnly forced or stripped, or the intended SameSite tier overridden. Patches Patched in undici v6.28.0, v7.29.0, and v8.9.0. Workarounds - Sanitize domain values against the RFC 1034 letter-digit-hyphen set before passing to setCookie. - Do not pass user-controlled data to the unparsed field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v3r7-h72x-cjcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-16729 Advisory: undici vulnerable to cookie attribute injection via unsanitized domain and unparsed setCookie fields IDs: CVE-2026-16729, GHSA-v3r7-h72x-cjcm Record: https://patchnext.com/advisories/cve-2026-16729 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.9.0, 7.29.0, 6.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected < 6.28.0; >= 7.0.0, < 7.29.0; >= 8.0.0, < 8.9.0; fixed in 6.28.0, 8.9.0, 7.29.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v3r7-h72x-cjcm (GitHub-reviewed advisory GHSA-v3r7-h72x-cjcm lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.9.0) Commands are suggestions: review each one before running it.
Loading voting…