undici vulnerable to downstream response desynchronization via retry interceptor
CVE-2026-16728GHSA-8xcm-r25x-g524
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.9.0, 7.29.0, 6.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- < 6.28.0>= 7.0.0, < 7.29.0>= 8.0.0, < 8.9.0
- Fixed in
- 6.28.0, 8.9.0, 7.29.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xcm-r25x-g524 lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-16728: 0.29% estimated exploitation activity in the next 30 days; percentile 21.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Undici's interceptors.retry() can deliver a response whose body length does not match the Content-Length header exposed to the application after a retry or resume of a partial response. Applications that use interceptors.retry() and forward upstream response headers and bodies downstream, for example proxy or gateway applications, may emit an invalid HTTP response with a stale Content-Length header. This can lead to downstream response desynchronization, connection hangs, or response corruption in clients or intermediaries that rely on the forwarded framing metadata. A malicious or faulty upstream can respond to a range request with a 206 Partial Content response such as: and then send only 99 bytes before closing the socket. interceptors.retry() can then retry with Range: bytes=99-99, receive the final byte, and deliver a 100-byte body to the application while the response headers still contain Content-Length: 300 from the first response. The bug requires interceptors.retry()…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8xcm-r25x-g524
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-16728 Advisory: undici vulnerable to downstream response desynchronization via retry interceptor IDs: CVE-2026-16728, GHSA-8xcm-r25x-g524 Record: https://patchnext.com/advisories/cve-2026-16728 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.9.0, 7.29.0, 6.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected < 6.28.0; >= 7.0.0, < 7.29.0; >= 8.0.0, < 8.9.0; fixed in 6.28.0, 8.9.0, 7.29.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8xcm-r25x-g524 (GitHub-reviewed advisory GHSA-8xcm-r25x-g524 lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.9.0) Commands are suggestions: review each one before running it.
Loading voting…