PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF
CVE-2026-16633GHSA-hq66-cqwq-w95j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdfjs-dist 6.2.108), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pdfjs-dist
- Affected
- >= 5.6.83, < 6.2.108
- Fixed in
- 6.2.108
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hq66-cqwq-w95j lists affected ranges: npm pdfjs-dist >=5.6.83 <6.2.108
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact If PDF.js is used to load a malicious PDF, and PDF.js is configured with enableScripting set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain. Patches Workarounds Set enableScripting to false or set a CSP.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hq66-cqwq-w95j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-16633 Advisory: PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF IDs: CVE-2026-16633, GHSA-hq66-cqwq-w95j Record: https://patchnext.com/advisories/cve-2026-16633 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pdfjs-dist 6.2.108. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pdfjs-dist: affected >= 5.6.83, < 6.2.108; fixed in 6.2.108 ## Suggested inspection (read-only) - `npm ls pdfjs-dist --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pdfjs-dist. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hq66-cqwq-w95j (GitHub-reviewed advisory GHSA-hq66-cqwq-w95j lists affected ranges: npm pdfjs-dist >=5.6.83 <6.2.108) Commands are suggestions: review each one before running it.
Loading voting…