Skip to content

← Actionable
Medium, CVSS 4.8amended

danger allows local OS command injection through crafted file paths

CVE-2026-16629GHSA-3x93-p86w-5jvh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (danger 13.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm danger

    Affected
    < 13.0.8
    Fixed in
    13.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-16629: 1.08% estimated exploitation activity in the next 30 days; percentile 65.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was identified in danger danger-js up to 13.0.7. Impacted is the function danger.git.diffForFile of the file source/platforms/git/localGetFileAtSHA.ts of the component CLI. Such manipulation of the argument File leads to os command injection. The attack needs to be performed locally. Upgrading to version 13.0.8 is recommended to address this issue. The name of the patch is 087a7290264cc6fb7154ea8c2552a7b2cb8b33a3. It is advisable to upgrade the affected component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3x93-p86w-5jvh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3x93-p86w-5jvh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-16629

Advisory: danger allows local OS command injection through crafted file paths
IDs: CVE-2026-16629, GHSA-3x93-p86w-5jvh
Record: https://patchnext.com/advisories/cve-2026-16629 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: danger 13.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm danger: affected < 13.0.8; fixed in 13.0.8

## Suggested inspection (read-only)
- `npm ls danger --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on danger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x93-p86w-5jvh (OSV record GHSA-3x93-p86w-5jvh lists affected ranges: npm danger >=0 <13.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-3x93-p86w-5jvh (GitHub-reviewed advisory GHSA-3x93-p86w-5jvh lists affected ranges: npm danger >=0 <13.0.8)

Commands are suggestions: review each one before running it.

Loading voting…