Skip to content

← Actionable
High, CVSS 7.3amended

AWS API MCP Server Security Policy Bypass via Startup Initialization Failure

CVE-2026-16584GHSA-29w2-fq35-v728

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (awslabs-aws-api-mcp-server 1.3.47), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-16584: 0.23% estimated exploitation activity in the next 30 days; percentile 13.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AWS API MCP Server is an open source Model Context Protocol (MCP) server that enables AI assistants to interact with AWS services and resources through AWS CLI commands. It provides programmatic access to manage your AWS infrastructure while maintaining proper security controls. It includes an optional, user-configured security policy that can deny or gate specific AWS operations. An issue exists where, if the data used to enforce this policy fails to initialize at server startup, the per-request policy check is silently skipped for the lifetime of the process. Impact On startup, the server loads data used to enforce the configured security policy. If that load fails, the server continues running without the enforcement data in place. In the default configuration, the per-request security check is then bypassed for the lifetime of the process: configured deny and gate rules are not consulted, and AWS API operations the policy was intended to restrict execute without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-29w2-fq35-v728

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-29w2-fq35-v728

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-16584

Advisory: AWS API MCP Server Security Policy Bypass via Startup Initialization Failure
IDs: CVE-2026-16584, GHSA-29w2-fq35-v728
Record: https://patchnext.com/advisories/cve-2026-16584 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: awslabs-aws-api-mcp-server 1.3.47. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI awslabs-aws-api-mcp-server: affected >= 0.2.13, < 1.3.47; fixed in 1.3.47

## Suggested inspection (read-only)
- `python -m pip show awslabs-aws-api-mcp-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on awslabs-aws-api-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-29w2-fq35-v728 (OSV record GHSA-29w2-fq35-v728 lists affected ranges: PyPI awslabs-aws-api-mcp-server >=0.2.13 <1.3.47 (fixed))
- Verified: https://github.com/advisories/GHSA-29w2-fq35-v728 (GitHub-reviewed advisory GHSA-29w2-fq35-v728 lists affected ranges: PyPI awslabs-aws-api-mcp-server >=0.2.13 <1.3.47)

Commands are suggestions: review each one before running it.

Loading voting…