Skip to content

← Actionable
High, CVSS 7.5amended

fast-uri vulnerable to host confusion via literal backslash authority delimiter

CVE-2026-16221GHSA-v2hh-gcrm-f6hx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.1, 3.1.4, 2.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    >= 2.3.1, <= 2.4.2>= 3.0.0, <= 3.1.3>= 4.0.0, <= 4.1.0
    Fixed in
    2.4.3, 4.1.1, 3.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-16221: 0.44% estimated exploitation activity in the next 30 days; percentile 37.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri v4.1.0 and earlier do not treat a literal backslash (U+005C) as an authority delimiter. Node's native WHATWG URL (used by fetch(), undici, and Node's http/https clients) normalizes \ to / for special schemes (http, https, ws, wss, ftp, file), so the two parsers extract different hosts from the same input string. For example, http://evil.com\@allowed.com is treated by fast-uri as host allowed.com with userinfo evil.com\, while Node's WHATWG URL parser and fetch() see host evil.com with path /@allowed.com. Applications that use fast-uri to enforce host-based policy (allowlists, denylists, loopback/SSRF filtering, redirect validation, outbound proxy routing) before passing the same URL into Node's URL or fetch() consumers see a policy/use desync and can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches Upgrade to fast-uri v4.1.1, v3.1.4, or v2.4.3. Workarounds None. Upgrade to the patched version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v2hh-gcrm-f6hx

  2. Revision 1 · created ·

    Published from osv record GHSA-v2hh-gcrm-f6hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-16221

Advisory: fast-uri vulnerable to host confusion via literal backslash authority delimiter
IDs: CVE-2026-16221, GHSA-v2hh-gcrm-f6hx
Record: https://patchnext.com/advisories/cve-2026-16221 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.1, 3.1.4, 2.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected >= 2.3.1, <= 2.4.2; >= 3.0.0, <= 3.1.3; >= 4.0.0, <= 4.1.0; fixed in 2.4.3, 4.1.1, 3.1.4

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v2hh-gcrm-f6hx (OSV record GHSA-v2hh-gcrm-f6hx lists affected ranges: npm fast-uri >=2.3.1 =3.0.0 =4.0.0 <4.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-v2hh-gcrm-f6hx (GitHub-reviewed advisory GHSA-v2hh-gcrm-f6hx lists affected ranges: npm fast-uri >=2.3.1 =3.0.0 =4.0.0 <=4.1.0)

Commands are suggestions: review each one before running it.

Loading voting…