Skip to content

← Actionable
High, CVSS 8.2amended

jsonpath has Arbitrary Code Injection via Unsafe Evaluation of JSON Path Expressions

CVE-2026-1615GHSA-87r5-mp6g-5w5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsonpath 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jsonpath

    Affected
    <= 1.2.1
    Fixed in
    1.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-1615: 1.17% estimated exploitation activity in the next 30 days; percentile 67.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary Code Injection (Remote Code Execution & XSS): A critical security vulnerability affects all versions of the jsonpath package. The library relies on the static-eval module to evaluate JSON Path expressions but fails to properly sanitize or sandbox the input. This allows an attacker to inject arbitrary JavaScript code into the JSON Path expression. When the library evaluates this expression, the malicious code is executed. Node.js Environments: This leads to Remote Code Execution (RCE), allowing an attacker to compromise the server. Browser Environments: This leads to Cross-Site Scripting (XSS), allowing an attacker to hijack user sessions or exfiltrate data. Affected Methods: The vulnerability triggers when untrusted data is passed to any method that evaluates a path, including: jsonpath.query jsonpath.nodes jsonpath.paths jsonpath.value jsonpath.parent jsonpath.apply Patches No Patch Available: Currently, all versions of jsonpath are vulnerable. There is no known…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-87r5-mp6g-5w5j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-87r5-mp6g-5w5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-1615

Advisory: jsonpath has Arbitrary Code Injection via Unsafe Evaluation of JSON Path Expressions
IDs: CVE-2026-1615, GHSA-87r5-mp6g-5w5j
Record: https://patchnext.com/advisories/cve-2026-1615 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsonpath 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsonpath: affected <= 1.2.1; fixed in 1.3.0

## Suggested inspection (read-only)
- `npm ls jsonpath --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsonpath.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-87r5-mp6g-5w5j (OSV record GHSA-87r5-mp6g-5w5j lists affected ranges: npm jsonpath >=0 <1.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-87r5-mp6g-5w5j (GitHub-reviewed advisory GHSA-87r5-mp6g-5w5j lists affected ranges: npm jsonpath >=0 <=1.2.1)

Commands are suggestions: review each one before running it.

Loading voting…