Skip to content

← Actionable
High, CVSS 8.4

jsii-diff: Command Injection via npm: package argument

CVE-2026-15895GHSA-wcx4-wpfv-mc5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsii-diff 1.131.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jsii-diff

    Affected
    < 1.131.0
    Fixed in
    1.131.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-15895: 1.08% estimated exploitation activity in the next 30 days; percentile 65.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary jsii-diff is a command line tool to compare the API differences between two jsii assemblies, and report errors if there are backwards-incompatible changes to the API. An issue exists where specially formatted command line arguments can be used to execute shell commands via this tool. Impact jsii-diff supports downloading packages to compare directly from NPM, so that you can compare a proposed candidate version of your jsii package with an already-published version, by passing an argument that looks like npm:<package-specifier. For example: By injecting a ; into the package-specifier part of that command, jsii-diff can be tricked into running shell commands. For example: This allows anyone that can control the command-line arguments to jsii-diff to run arbitrary commands with the same permissions as the jsii-diff command itself. Patches This issue has been addressed in jsii-diff version 1.131.0. We recommend upgrading to the latest version and ensuring any forked or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wcx4-wpfv-mc5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-15895

Advisory: jsii-diff: Command Injection via npm: package argument
IDs: CVE-2026-15895, GHSA-wcx4-wpfv-mc5c
Record: https://patchnext.com/advisories/cve-2026-15895 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsii-diff 1.131.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsii-diff: affected < 1.131.0; fixed in 1.131.0

## Suggested inspection (read-only)
- `npm ls jsii-diff --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsii-diff.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wcx4-wpfv-mc5c (GitHub-reviewed advisory GHSA-wcx4-wpfv-mc5c lists affected ranges: npm jsii-diff >=0 <1.131.0)

Commands are suggestions: review each one before running it.

Loading voting…