Snowflake SQLAlchemy affected by SQL injection and local file disclosure vulnerabilities
CVE-2026-15736GHSA-8g6f-qw9x-4q6q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-sqlalchemy 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI snowflake-sqlalchemy
- Affected
- >= 1.1.6, < 1.11.0
- Fixed in
- 1.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8g6f-qw9x-4q6q lists affected ranges: PyPI snowflake-sqlalchemy >=1.1.6 <1.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8g6f-qw9x-4q6q lists affected ranges: PyPI snowflake-sqlalchemy >=1.1.6 <1.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-15736: 0.38% estimated exploitation activity in the next 30 days; percentile 31.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Snowflake SQLAlchemy versions prior to 1.11.0 contain several security vulnerabilities, including: Improper handling of user-supplied column identifiers in merge operations could allow SQL injection through attacker-controlled input keys. An attacker may be able to exploit this through request field names in a dynamic upsert endpoint, potentially enabling read access to data visible to the application's database role or modification of values within the same MERGE statement. Improper literal rendering of bound parameters when building certain Snowflake-specific table creation queries could allow SQL injection. An attacker may be able to exploit this by supplying a crafted string to any application endpoint that passes user-controlled data through the affected query-building API, potentially causing arbitrary data exfiltration within the scope of the connection role. Improper forwarding of connection configuration parameters could allow an attacker to cause the library to read…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8g6f-qw9x-4q6q
- Revision 1 · created ·
Published from osv record GHSA-8g6f-qw9x-4q6q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-15736 Advisory: Snowflake SQLAlchemy affected by SQL injection and local file disclosure vulnerabilities IDs: CVE-2026-15736, GHSA-8g6f-qw9x-4q6q Record: https://patchnext.com/advisories/cve-2026-15736 (revision 2, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snowflake-sqlalchemy 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI snowflake-sqlalchemy: affected >= 1.1.6, < 1.11.0; fixed in 1.11.0 ## Suggested inspection (read-only) - `python -m pip show snowflake-sqlalchemy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snowflake-sqlalchemy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8g6f-qw9x-4q6q (OSV record GHSA-8g6f-qw9x-4q6q lists affected ranges: PyPI snowflake-sqlalchemy >=1.1.6 <1.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8g6f-qw9x-4q6q (GitHub-reviewed advisory GHSA-8g6f-qw9x-4q6q lists affected ranges: PyPI snowflake-sqlalchemy >=1.1.6 <1.11.0) Commands are suggestions: review each one before running it.
Loading voting…