Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') in GitLab
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitlab 19.5.1, 19.4.3, 19.3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami gitlab
- Affected
- >= 10.1.0, < 19.3.6>= 19.4.0, < 19.4.3>= 19.5.0, < 19.5.1
- Fixed in
- 19.4.3, 19.5.1, 19.3.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-gitlab-2026-15723 lists affected ranges: Bitnami gitlab >=10.1.0 =19.4.0 =19.5.0 <19.5.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-15723: 0.43% estimated exploitation activity in the next 30 days; percentile 37.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when OmniAuth SAML and LDAP auto-linking were both enabled, an authenticated user could have taken over an existing LDAP-backed account without any interaction from the targeted user, due to improper input sanitization in the LDAP email lookup path used during OmniAuth identity linking.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record BIT-gitlab-2026-15723
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-15723
Advisory: Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') in GitLab
IDs: CVE-2026-15723
Record: https://patchnext.com/advisories/cve-2026-15723 (revision 1, source checked 30 Oct 2026, 07:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitlab 19.5.1, 19.4.3, 19.3.6. A vendor fix does not mean a deployment is fixed.
## Affected components
- Bitnami gitlab: affected >= 10.1.0, < 19.3.6; >= 19.4.0, < 19.4.3; >= 19.5.0, < 19.5.1; fixed in 19.4.3, 19.5.1, 19.3.6
## Suggested inspection (read-only)
- Bitnami gitlab: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitlab.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/BIT-gitlab-2026-15723 (OSV record BIT-gitlab-2026-15723 lists affected ranges: Bitnami gitlab >=10.1.0 =19.4.0 =19.5.0 <19.5.1 (fixed))
Commands are suggestions: review each one before running it.Loading voting…