foreman_kubevirt disables SSL verification if a Certificate Authority (CA) certificate is not explicitly set
CVE-2026-1531GHSA-2qxw-7fmx-gqfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (foreman_kubevirt 0.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems foreman_kubevirt
- Affected
- < 0.4.3
- Fixed in
- 0.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2qxw-7fmx-gqfm lists affected ranges: RubyGems foreman_kubevirt >=0 <0.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-1531: 0.29% estimated exploitation activity in the next 30 days; percentile 21.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in foremankubevirt. When configuring the connection to OpenShift, the system disables SSL verification if a Certificate Authority (CA) certificate is not explicitly set. This insecure default allows a remote attacker, capable of intercepting network traffic between Satellite and OpenShift, to perform a Man-in-the-Middle (MITM) attack. Such an attack could lead to the disclosure or alteration of sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2qxw-7fmx-gqfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1531 Advisory: foreman_kubevirt disables SSL verification if a Certificate Authority (CA) certificate is not explicitly set IDs: CVE-2026-1531, GHSA-2qxw-7fmx-gqfm Record: https://patchnext.com/advisories/cve-2026-1531 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: foreman_kubevirt 0.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems foreman_kubevirt: affected < 0.4.3; fixed in 0.4.3 ## Suggested inspection (read-only) - RubyGems foreman_kubevirt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on foreman_kubevirt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2qxw-7fmx-gqfm (GitHub-reviewed advisory GHSA-2qxw-7fmx-gqfm lists affected ranges: RubyGems foreman_kubevirt >=0 <0.4.3) Commands are suggestions: review each one before running it.
Loading voting…