Undici has Unbounded Memory Consumption in WebSocket permessage-deflate Decompression
CVE-2026-1526GHSA-vrm6-8vpv-qv8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 7.24.0, 6.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- < 6.24.0>= 7.0.0, < 7.24.0
- Fixed in
- 6.24.0, 7.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vrm6-8vpv-qv8q lists affected ranges: npm undici >=0 =7.0.0 <7.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vrm6-8vpv-qv8q lists affected ranges: npm undici >=0 =7.0.0 <7.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-1526: 1.20% estimated exploitation activity in the next 30 days; percentile 68.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The undici WebSocket client is vulnerable to a denial-of-service attack via unbounded memory consumption during permessage-deflate decompression. When a WebSocket connection negotiates the permessage-deflate extension, the client decompresses incoming compressed frames without enforcing any limit on the decompressed data size. A malicious WebSocket server can send a small compressed frame (a "decompression bomb") that expands to an extremely large size in memory, causing the Node.js process to exhaust available memory and crash or become unresponsive. The vulnerability exists in the PerMessageDeflate.decompress() method, which accumulates all decompressed chunks in memory and concatenates them into a single Buffer without checking whether the total size exceeds a safe threshold. Impact - Remote denial of service against any Node.js application using undici's WebSocket client - A single compressed WebSocket frame of ~6 MB can decompress to ~1 GB or more - Memory exhaustion…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vrm6-8vpv-qv8q
- Revision 1 · created ·
Published from osv record GHSA-vrm6-8vpv-qv8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1526 Advisory: Undici has Unbounded Memory Consumption in WebSocket permessage-deflate Decompression IDs: CVE-2026-1526, GHSA-vrm6-8vpv-qv8q Record: https://patchnext.com/advisories/cve-2026-1526 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 7.24.0, 6.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected < 6.24.0; >= 7.0.0, < 7.24.0; fixed in 6.24.0, 7.24.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vrm6-8vpv-qv8q (OSV record GHSA-vrm6-8vpv-qv8q lists affected ranges: npm undici >=0 =7.0.0 <7.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vrm6-8vpv-qv8q (GitHub-reviewed advisory GHSA-vrm6-8vpv-qv8q lists affected ranges: npm undici >=0 =7.0.0 <7.24.0) Commands are suggestions: review each one before running it.
Loading voting…