@fastify/static vulnerable to route guard bypass via path traversal
CVE-2026-15074GHSA-83w8-p2f5-377r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/static 10.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fastify/static
- Affected
- <= 10.1.0
- Fixed in
- 10.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-83w8-p2f5-377r lists affected ranges: npm @fastify/static >=0 <10.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-83w8-p2f5-377r lists affected ranges: npm @fastify/static >=0 <=10.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-15074: 0.67% estimated exploitation activity in the next 30 days; percentile 52.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact @fastify/static is vulnerable to a bypass of route-based middleware and guards via non-leading .. and %2E%2E path segments. find-my-way does not normalize .. when matching routes, so a request such as /foo/../deep/secret.txt matches the static plugin's catch-all instead of the guarded /deep/. The getPathnameForSend helper introduced by the fix for GHSA-x428-ghpx-8j92 only guards against the %2F variant; .. and %2E%2E survive the decodeURI + encodeURI round-trip and are then collapsed away by @fastify/send's path.normalize before its own traversal guard runs. Applications that rely on route-based middleware or guards to protect files served by @fastify/static can be bypassed with non-leading dot-dot path segments. Patches Upgrade to @fastify/static 10.1.1. Workarounds Do not use route-based middlewares or guards to protect files served by @fastify/static.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-83w8-p2f5-377r
- Revision 1 · created ·
Published from osv record GHSA-83w8-p2f5-377r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-15074 Advisory: @fastify/static vulnerable to route guard bypass via path traversal IDs: CVE-2026-15074, GHSA-83w8-p2f5-377r Record: https://patchnext.com/advisories/cve-2026-15074 (revision 2, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fastify/static 10.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fastify/static: affected <= 10.1.0; fixed in 10.1.1 ## Suggested inspection (read-only) - `npm ls @fastify/static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fastify/static. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-83w8-p2f5-377r (OSV record GHSA-83w8-p2f5-377r lists affected ranges: npm @fastify/static >=0 <10.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-83w8-p2f5-377r (GitHub-reviewed advisory GHSA-83w8-p2f5-377r lists affected ranges: npm @fastify/static >=0 <=10.1.0) Commands are suggestions: review each one before running it.
Loading voting…