Craft CMS: Missing authorization check allows non-admin control panel users to reorder Global Sets
CVE-2026-14793GHSA-9p7c-v5x3-rfx8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.10.3, 4.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.0.0-RC1, < 4.18.1>= 5.0.0-RC1, < 5.10.3
- Fixed in
- 4.18.1, 5.10.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9p7c-v5x3-rfx8 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9p7c-v5x3-rfx8 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/ · score source
- EPSS
- CVE-2026-14793: 0.39% estimated exploitation activity in the next 30 days; percentile 32.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The reorder-sets action in Craft CMS’s GlobalsController is missing the requireAdmin() check that the adjacent save-set and delete-set actions both enforce. Any authenticated control panel user can POST to /actions/globals/reorder-sets and permanently reorder all global sets in the project config, regardless of whether they have admin access. The reordering is written through to the project config and persists across requests. Description GlobalsController exposes three administrative actions for managing global set structure. Two of them gate on admin status; the third does not. Prerequisites - A Craft CMS instance with at least two global sets and a non-admin control panel user account. Impact A non-admin control panel user can reorder all global sets. While this does not expose or modify content, reordering global sets modifies the project config -- a versioned artifact that is typically committed to source control and deployed across environments. An attacker can create noise in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9p7c-v5x3-rfx8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9p7c-v5x3-rfx8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-14793 Advisory: Craft CMS: Missing authorization check allows non-admin control panel users to reorder Global Sets IDs: CVE-2026-14793, GHSA-9p7c-v5x3-rfx8 Record: https://patchnext.com/advisories/cve-2026-14793 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.10.3, 4.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.0.0-RC1, < 4.18.1; >= 5.0.0-RC1, < 5.10.3; fixed in 4.18.1, 5.10.3 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9p7c-v5x3-rfx8 (OSV record GHSA-9p7c-v5x3-rfx8 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.3 (fixed)) - Verified: https://github.com/advisories/GHSA-9p7c-v5x3-rfx8 (GitHub-reviewed advisory GHSA-9p7c-v5x3-rfx8 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.3) Commands are suggestions: review each one before running it.
Loading voting…